FuelMaster transactions may be delayed

Incident Report for Fleetio

Resolved

The issue affecting FuelMaster fuel transactions is resolved. All historical transactions have been processed and restored.
Posted Jul 21, 2025 - 12:36 CDT

Investigating

Some customers are currently experiencing sync issues with the FuelMaster integration. Fuel Transactions may be delayed for a period of time, No data loss is expected and all fuel transactions will be able to be restored once the issue is resolved.
Posted Jul 18, 2025 - 15:51 CDT
This incident affected: Fuel Card Integrations (Fuelmaster Integration).