"Inspection Form Incomplete" error on Fleetio Go Android
Incident Report for Fleetio
Postmortem

On December 18th we released Fleetio Go 3.4.2 to the Google Play Store. This version improved how Fleetio Go handles completing an inspection internally, but introduced an error which caused previously resolved Issues to remain cached on users' devices. The device failed to recognize when Issues were resolved elsewhere, forced the user to include previously resolved Issues via an inspection, and raised an error when submitting the inspection due to the inconsistency. Users were then stuck as there was no way to tell the app which Issues had been resolved and could be safely ignored.

Our mobile engineers worked to fix this problem and on December 28th released Fleetio Go 3.4.2.2, which did two things:

  1. The app is now able to recognize when Issues are resolved elsewhere by other users.

  2. Ensures that Issue resolutions and open Issues are handled appropriately when completing inspections. 

We're also working to improve our automated testing suite to account for more scenarios to make critical errors on inspections easier to diagnose before they make it to the app stores. While we currently have a robust testing suite, our goal is to add as many of our users’ workflows as possible. We apologize for the inconvenience this issue caused and thank you for your patience while we worked on a resolution.

Posted Jan 12, 2021 - 14:23 CST

Resolved
We are confident this issue is resolved after monitoring the fix we released last week. Thank you for your patience while we worked on a resolution.
Posted Jan 07, 2021 - 11:14 CST
Monitoring
We have been monitoring this incident after releasing the 3.4.2.2 Android hotfix last week. We have not recorded any reports of this issue since that hotfix release.

Please feel free to reach out to Support at help@fleetio.com if you need further assistance.

Thank you!
Posted Jan 06, 2021 - 11:09 CST
Update
Our engineers are continuing to work on a permanent fix for this issue. We've identified that this issue will be able to be resolved via a server-side fix and will not require users to update to a new version of Fleetio Go. The hotfix we released last week, version 3.4.2.2, should correct all but a few outlying issues. We will update the Status Page once that final permanent fix is released. Please continue to reach out to Support via help@fleetio.com with any questions and we will be happy to assist.
Posted Jan 04, 2021 - 17:10 CST
Update
Please continue to use the hotfix that is currently in the Google Play Store to help with this issue (Version 3.4.2.2) You can find it here: https://play.google.com/store/apps/details?id=com.fleetio.go_app&hl=en_US&gl=US

Our engineers are continuing their efforts to work this issue as their primary task and have made significant progress. A more permanent fix is currently undergoing rigorous testing. We are anticipating the release of that fix to be live in the Google Play Store next week.
Posted Dec 31, 2020 - 17:22 CST
Update
We have just released a hotfix to the Google Play Store to help with this issue (Version 3.4.2.2)
You can find it here: https://play.google.com/store/apps/details?id=com.fleetio.go_app&hl=en_US&gl=US

This hotfix is a temporary workaround while our engineers work to implement a permanent fix. The workaround is as follows:

Users will still be stopped from submitting an inspection if the issue has been confirmed after the Inspection has been started.
However, the user will only need to exit the Inspection list and then access the inspection again.
The user will then see that issue has fallen off the inspection and they will be able to submit the inspection without having to restart it.

We will reach out as soon as the permanent fix is available on the Play Store.

Thanks again for your patience while we continue to correct this issue!
Posted Dec 28, 2020 - 16:40 CST
Update
Our developers are continuing to work on a fix for this issue this morning. As soon as we have more information, we will post it here.

While we continue to work to correct this issue, there are two workarounds that can help get past this error:

1. Restart the inspection, then go back to the listing screen and pull down to refresh. Then go back into the inspection and you are able to get around the validation error.

2. Webapp submissions will work if you are receiving this error. You can submit an inspection via a mobile (or desktop) browser and this should help bypass the error.

Please feel free to reach out to Support at help@fleetio.com if you are having this issue so we can follow up with you as soon as we have corrected this.

Thank you for your patience while we continue to work on this issue!
Posted Dec 28, 2020 - 10:05 CST
Identified
We've identified the issue and are continuing to work on a fix.

While we continue to work to correct this issue, there are two workarounds that can help get past this error:

1. Restart the inspection, then go back to the listing screen and pull down to refresh. Then go back into the inspection and you are able to get around the validation error.

2. Webapp submissions will work if you are receiving this error. You can submit an inspection via a mobile (or desktop) browser and this should help bypass the error.

Thank you for your patience while we continue to work on this issue!
Posted Dec 23, 2020 - 12:26 CST
Update
While we continue to work to correct this issue, there are two workarounds that can help get past this error:

1. Restart the inspection, then go back to the listing screen and pull down to refresh. Then go back into the inspection and you are able to get around the validation error.

2. Webapp submissions will work if you are receiving this error. You can submit an inspection via a mobile (or desktop) browser and this should help bypass the error.

Thank you for your patience while we continue to work on this issue!
Posted Dec 22, 2020 - 15:28 CST
Investigating
We are currently investigating an issue when attempting to complete some inspections in Fleetio Go on the Android OS. The error message reads "Inspection Form Incomplete, Please complete the following inspection items before submitting: Issue Resolution" This will occur if the resolved issue has been confirmed by a second user after the first user starts the inspection. We apologize for the inconvenience this error may cause. If you are having this issue, please reach out to Support at help@fleetio.com. We will be happy to help. We will also update this Status Page as we know more.
Posted Dec 22, 2020 - 15:02 CST
This incident affected: Fleetio Go Mobile Application.