Degraded Performance
Incident Report for Fleetio
Resolved
We have identified the source of the issues and have implemented a fix. We apologize for any inconvenience.
Posted Sep 26, 2023 - 11:58 CDT
Investigating
We are currently investigating degraded performance in the Fleetio application, which is preventing affecting actions like signing in and creating new records.

We apologize for the inconvenience and will update this page as soon as more information becomes available.
Posted Sep 26, 2023 - 11:06 CDT
This incident affected: Fleetio Web Application & API and Fleetio Go Mobile Application.