Login Issues in Fleetio Go Android
Incident Report for Fleetio
Postmortem

On Thursday, May 5th at 1:17 PM CST version 4.7.1 of Fleetio Go on Android was promoted to Production and began to be available for update on Google Play. We received our first customer report of the app crashing on launch on Friday, May 6th at 7:43 AM CST. Upon investigation, we determined that a development build had inadvertently replaced the 4.7.1 release that was originally staged. We then rolled back to the previous working release version 4.7.0 and deployed the hot fix as version 4.7.0.1 which was made available for update on Google Play at 11:40 AM CST.

With every release of Fleetio Go we perform rigorous regression testing of the app to ensure problems like these don’t arise. This testing occurred with the 4.7.1 release that was originally prepared for deployment, but a development build inadvertently overwrote the staged build from a developer’s local machine after QA had already occurred. We are taking the following steps to safeguard against these type of scenarios in the future:

  • Restrict the access in which a build can be uploaded to Google Play for release.
  • Change our promotion process to take advantage of alpha and beta lanes to ensure the build being tested is what is deployed to production.
  • Utilize phased rollouts and beta testing groups to ensure app quality with a smaller user base before a release makes it out to all customers.

We realize that Fleetio Go is mission critical for our users. We would like to apologize for the adverse effects this outage had on our customers. As always, we'll continue to analyze the events involving this incident and will use these learnings to improve Fleetio.

Posted May 18, 2022 - 09:50 CDT

Resolved
We've released a hotfix Android version of Fleetio Go via the Google Play Store, version 4.7.7.1, which corrects this issue. Please have you and your team update to this latest version. Please let us know if we can be of further assistance by reaching out to our Support Team at help@fleetio.com

Thank you for being so patient while we worked on this resolution!
Posted May 06, 2022 - 11:49 CDT
Identified
We've identified an issue in our system that is causing some Android Fleetio Go users to not log in and some Webap users receiving Reference ID error codes. Our Engineers are actively working to correct this. We'll update this page as soon as we have more information. If you have any questions please reach out to our Support Team at help@fleetio.com.
Posted May 06, 2022 - 08:30 CDT
Update
We are continuing to investigate this issue.
Posted May 06, 2022 - 08:21 CDT
Update
We are continuing to investigate this issue.
Posted May 06, 2022 - 08:20 CDT
Investigating
We are currently investigating reports of slow speeds and customers not being able to log into Fleetio. We apologize for the inconvenience and will update this Status Page as soon as we have more information. If you are affected or have any questions, please reach out to our Support Team at help@fleetio.com
Posted May 06, 2022 - 08:02 CDT
This incident affected: Fleetio Web Application & API and Fleetio Go Mobile Application.