Fleetio Go: Push Notification Deliverability

Incident Report for Fleetio

Resolved

This incident has been resolved, and push notifications should be delivering as expected.
Posted May 27, 2026 - 12:09 CDT

Identified

Our team has identified the issue. We are working to test and validate, and hope to provide an update on the resolution soon.
Posted May 27, 2026 - 11:07 CDT

Investigating

We are currently investigating an issue with the Fleetio Go mobile app related to its ability to deliver push notifications to mobile devices. We will provide updates as they become available.
Posted May 27, 2026 - 09:37 CDT
This incident affected: Fleetio Go Mobile Application.