Fleetio Web Slowness & Time-outs

Incident Report for Fleetio

Resolved

This incident has been resolved.
Posted Oct 02, 2025 - 14:34 CDT

Investigating

Our developers have identified an issue impacted by a third-party vendor that causes slow load times and even time-outs when loading the Fleetio Web app. We are currently investigating the resolution and will follow up with more information as it becomes available.
Posted Oct 02, 2025 - 09:50 CDT
This incident affected: Fleetio Web Application & API.