Filestack service degraded
Incident Report for Fleetio
Resolved
This incident has been resolved.
Posted Aug 29, 2023 - 22:07 CDT
Update
We are currently investigating an outage with our 3rd party file hosting provider. This is currently impacting users' ability to upload, view, and download documents and photos as well as the ability to attach photos to inspection items in Fleetio Go.


We apologize for the inconvenience and will update this page as soon as more information becomes available.
Posted Aug 29, 2023 - 19:41 CDT
Investigating
Filestack services, like viewing documents/photos, exporting files, attaching inspection items in Fleetio Go, retrieving reports, etc. is currently degraded. Our team is investigating and working to resolve the issue as quickly as possible.
Posted Aug 29, 2023 - 19:21 CDT
This incident affected: Fleetio Web Application & API, Fleetio Go Mobile Application and File Storage (File Uploads, File Downloads, File Storage).