Webhook Event Delay

Incident Report for Fleetio

Resolved

Webhook event performance has returned to normal. We're monitoring and will post subsequent updates if needed.
Posted Oct 27, 2025 - 14:10 CDT

Investigating

We are currently investigating an issue causing some webhook event deliveries to fail. This may result in delayed or missing webhook notifications. Our engineering team is actively working to identify the cause. Updates will be provided as soon as more information is available.
Posted Oct 27, 2025 - 13:33 CDT
This incident affected: Fleetio Web Application & API.