Receiving Purchase Orders
Incident Report for Fleetio
Resolved
This incident has been resolved.
Posted Mar 09, 2023 - 00:43 CST
Update
This has been resolved.
Posted Mar 09, 2023 - 00:42 CST
Investigating
There is currently an issue preventing purchase orders from being received. Our team is aware of the issue and we are currently investigating.
Posted Mar 08, 2023 - 14:51 CST
This incident affected: Fleetio Web Application & API.