Fleetio Errors

Incident Report for Fleetio

Resolved

This incident has been resolved.
Posted Nov 10, 2025 - 16:03 CST

Update

We are continuing to monitor for any further issues.
Posted Nov 10, 2025 - 16:03 CST

Monitoring

Services on the Fleetio platform have now been restored, but we anticipate degraded performance to continue for the next few hours as we complete final checks.
Posted Nov 10, 2025 - 11:19 CST

Update

We are continuing to investigate this issue.
Posted Nov 10, 2025 - 09:35 CST

Investigating

We’re currently investigating an issue that is preventing access to the Fleetio platform. Our team is actively working to restore full functionality as quickly as possible.
Posted Nov 10, 2025 - 09:01 CST
This incident affected: Fleetio Web Application & API.