Phone Support Unavailable

Incident Report for Fleetio

Resolved

This has been resolved, and phone channels have been restored.
Posted Sep 01, 2026 - 14:56 CDT

Monitoring

Fleetio's Phone Support channel is currently unavailable due to an outage with our service provider. In the meantime, please start a Live Chat in the Fleetio web platform, Fleetio Go, or Vendor Portal for support. For more information, please visit https://www.fleetio.com/contact.
Posted Sep 01, 2026 - 13:10 CDT