FuelCloud & Fill-Rite transaction delays

Incident Report for Fleetio

Resolved

Users were experiencing FuelCloud & Fill-Rite transaction delays. However, our teams have resolved the issue, and the system should be back to normal performance. We apologize for any inconvenience this may have caused.

If you need additional information, please contact our support team at help@fleetio.com.
Posted Aug 01, 2025 - 14:55 CDT

Investigating

Transactions are currently delayed, but no data loss has occurred. To restore the service, all historical data will be synced into Fleetio. We'll provide an update once the historical data has been synced.
Posted Jul 25, 2025 - 14:49 CDT
This incident affected: Fuel Card Integrations (Fill-Rite FMS Integration, FuelCloud Integration).