Repair Order Degradation

Incident Report for Fleetio

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 13:03 CDT

Investigating

We are currently investigating an issue that is preventing shops from creating repair orders in Fleetio.
Posted Apr 02, 2026 - 10:46 CDT
This incident affected: Fleetio Web Application & API.