Email Delivery Error

Incident Report for Fleetio

Resolved

This incident has been resolved.
Posted Apr 21, 2025 - 14:48 CDT

Identified

We are currently aware of an issue preventing successful email responses. Our team is investigating and working to resolve the issue as quickly as possible. We’ll provide updates as soon as we have more information. In the interim, please reach out to our Support Team through Live Chat or Phone for any support inquiries. Thank you for your patience!
Posted Apr 21, 2025 - 14:22 CDT
This incident affected: Hosting Infrastructure (Emails).