Intermittent issues with our Marketing Site, Fleetio.com
Incident Report for Fleetio
Resolved
This incident has been resolved by our third party service. Have a great evening!
Posted Oct 08, 2020 - 15:25 CDT
Identified
The issue has been identified and our third party service is implementing a fix.
Posted Oct 08, 2020 - 14:02 CDT
Investigating
We are currently investigating some reports of some of our marketing site, fleetio.com, pages not loading. This does not affect our webapp or mobile app, Fleetio Go.
Posted Oct 08, 2020 - 14:00 CDT