Unable to select Vendors from Dropdown
Incident Report for Fleetio
Resolved
This incident has been resolved.
Posted Sep 28, 2020 - 11:08 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 28, 2020 - 10:48 CDT
Identified
The root cause of this issue has been identified and we are working on a fix that should be available shortly.
Posted Sep 28, 2020 - 10:32 CDT
Investigating
We are currently investigating an issue where Vendors are not able to be selected from dropdown menus in Fleetio. We apologize for the inconvenience.
Posted Sep 28, 2020 - 10:25 CDT