Verizon Networkfleet Not Authenticating
Incident Report for Fleetio
Resolved
This issue has been resolved. All Networkfleet integrations that were down have been brought back online and should function properly going forward. Thank you for your patience and our sincere apologies for any disruption to your integration this may have caused.

Full details below:

Twice in the past couple months, a large number of Networkfleet integrations in Fleetio entered a failed authentication state based on a response from the Networkfleet system. A few hours / days later, if we attempt to reauthenticate these integrations, they worked again. Investigation revealed that when Verizon Networkfleet is down for maintenance or having system stability problems, it was responding in such a way to Fleetio that seemed to communicate that the user's credentials were incorrect instead of that the server was temporarily down or having problems. So when Fleetio got that response back, we would mark those credentials as incorrect, which then prevented the integration from ever downloading odometers, faults, etc. going forward. The only way to get out of this situation and get data flowing again was for a user to manually reauthenticate via Fleetio's UI using their unchanged username and password.

Going forward, we have made changes in Fleetio to make the connection between our systems more robust so that if Networkfleet is down for a short time or sends this same response, Fleetio will no longer disable the Networkfleet integration. This should result in more reliable and stable Networkfleet integrations going forward.
Posted Apr 29, 2020 - 17:06 CDT
Investigating
We are currently investigating an issue with the Verizon Networkfleet integration no longer authenticating with correct credentials. We apologize for the inconvenience! We will update this status page as we learn more from our Product Team's investigation.
Posted Apr 28, 2020 - 11:39 CDT
This incident affected: GPS Integrations (Verizon Networkfleet Integration).