Hosting Platform Timeout
Incident Report for Fleetio
Resolved
All systems are operational.
Posted Jan 19, 2018 - 10:18 CST
Investigating
The Fleetio hosting platform is experiencing degraded performance with occasional timeouts. We are keeping a close watch on full restoration and will update as more information is received.
Posted Jan 19, 2018 - 09:33 CST